Cookies used in this website are gluten free, wheat free and dairy free. By using this website you agree to our use of cookies. More Info
Guest
Login Below
Join Us On Social Media!
   
Get The Model Boats App!
Apple App Store
Android app on Google Play


Help Support This Website
£
or enter custom amount

(Non Contributor)

Help support this free
website and donate.



£285 a year is needed to keep the website and apps online. Please consider donating £5 or more to help towards these fees.
All donations are securely managed through PayPal. Amounts donated are not published online.

Many thanks for your kind support.

Model Boats Website Team


Donation History
December 2018: 5 people
November 2018: 11 people
October 2018: 9 people
September 2018: 13 people
August 2018: 5 people
July 2018: 8 people
June 2018: 8 people
May 2018: 7 people
April 2018: 24 people
March 2018: 10 people


Unique Visitors This Month

Website Members

Terms and Conditions
Privacy Policy
Advertising
Contact


Model Boats Website
Active Users (20)
Login or Register
To Remove This Ad

Login or Register
To Remove This Ad
>> Home > Forum > Electrical Related > Connecting ESP ?
Connecting ESP ?
(4567 views)
Author Message
kwjg51
(Petty Officer)





Forum Posts: 10
11th May 2015 18:06  
>> Permalink
mdlbt.com/17530

Hello all - I have just re kindled an old Interest In RC boats and have an Aerokit Sea Commander at the electrics stage. I have a two ch. Futaba controller and a Electronize 43HX esc. The thin red, black & white leads from the esc connect to channel 2 of the Futaba receiver. How do I know which of the three pins to connect the three coloured leads to as they are not pre fitted with a correct polarity plugin ( like the plugs already fitted to the servo unit) ?
Many thanks,
Keith.

McCluskey
(Commander)





Forum Posts: 5
11th May 2015 19:13  
>> Permalink
mdlbt.com/17531

HI there

The light coloured wire needs to go to the top pin as you look down on your RX.

Naturally the red and black are your power so you can try connecting the power lead to RX and observe which pins they use.

Hope this helps you.
Roy


Roy McCluskey
kwjg51
(Petty Officer)





Forum Posts: 10
11th May 2015 21:11  
>> Permalink
mdlbt.com/17532

Thanks Roy - I'll go back to It and have another look. My concern Is In getting the polarity wrong and possibly damaging the units.

Regards,

Keith.

Dave M
(Fleet Admiral!)





Forum Posts: 1527
12th May 2015 16:09  
>> Permalink
mdlbt.com/17549

HI Keith
It Is very Important to connect the correct polarity to the RX. Electronize used to supply two plug blanks on for Futaba with a small tang along one side and another without.
The white lead (signal pulse) need to go to the socket nearest to the tang end of the plug, the red Is In the middle ( ve) and the black (-ve) next.
You can use either type of socket plug but the Futaba helps you Insert the plug correctly. You will not damage the Rx by putting the black to the pulse Input, It just won't work. The red wire Is always In the centre pin with Futaba equipment.
Dave


Live long and prosper

Dave
kwjg51
(Petty Officer)





Forum Posts: 10
12th May 2015 17:40  
>> Permalink
mdlbt.com/17550

Thanks Dave - that clarifies things nicely. I got It to work on the bench today but then It stopped. I did some checks but no go ! The back of the esc was quite hot - Too much so for my liking. I have had the esc for 12 years but It was never out of the box so It should be ok. I am using the Caldercraft 750s motor supplied and a 12v 7amp lead acid battery to set It up. I hope I haven't cooked something !

Thanks for the Interest.

Keith.

Dave M
(Fleet Admiral!)





Forum Posts: 1527
12th May 2015 19:11  
>> Permalink
mdlbt.com/17552

HI Keith
The ESC should not be getting hot If the motor Is not loaded. I would check that you can turn the prop and motor freely and correct any binding.
If I remember correctly your ESC has a built In BEC, and you should not connect a separate battery (4.8v) to the receiver. The ESC has a power MOSFET and Voltage reg attached to the back plate so heat suggests this may be damaged. You have switched on the ESC? (assuming It has the BEC circuit)
Did you use a battery with the ESC and have the black (-ve) wire connected to the middle pin during your tests? Could you have reversed the main battery connection? The MOSFET and Internal IC can both be damaged by even momentary wrong connection.
Dave


Live long and prosper

Dave
kwjg51
(Petty Officer)





Forum Posts: 10
12th May 2015 20:41  
>> Permalink
mdlbt.com/17554

No Dave my esc does not have bec and Is powered by 4 AA's. Motor and prop shaft are free but, on carefully reading your reply, I am concerned that I may have stupidly reversed polarity when connecting esc to rx this morning - further Investigation underway In the shed this evening !

Many thanks,

Keith.

kwjg51
(Petty Officer)





Forum Posts: 10
12th May 2015 22:35  
>> Permalink
mdlbt.com/17557

Update - I think the esc Is toasted. When I push the throttle there Is a 'click' from the esc and I can see the switch engage but no power to the motor !

Keith.

Dave M
(Fleet Admiral!)





Forum Posts: 1527
13th May 2015 09:50  
>> Permalink
mdlbt.com/17559

HI Keith
There Is good news and not so good.
From your description the IC Is OK as you can hear the relay switching from fwd to rev.
The bad news Is your MOSFET has blown. Your ESC Is no longer supplied by Electronize but I believe It may have a max current of 15 amp. Your motor Is rated at 1amp unloaded so the ECS should have been ample for your purpose.
I have used many Electronize ESCs and repaired those I have blown. The company used to offer a repair service but I believe this may be discontinued. If you have a friend who Is Into electronics It Is a fairly simple job to replace the part with a similar rated component costing under £5.
If you have a model boat club near you may be able to find someone local to help.
I hope this won't stop you rekindling your Interest In restoring the model.
Dave


Live long and prosper

Dave
jarvo
(Fleet Admiral!)





Forum Posts: 556
13th May 2015 10:35  
>> Permalink
mdlbt.com/17560

HI Keith

Try ringing Electronize, they may be able to help,

Mark


Etherow Model Boat Club
kwjg51
(Petty Officer)





Forum Posts: 10
13th May 2015 12:08  
>> Permalink
mdlbt.com/17561

Thanks guys - working on It !

Keith.

kwjg51
(Petty Officer)





Forum Posts: 10
22nd May 2015 00:25  
>> Permalink
mdlbt.com/17689

Thanks Dave - looks like you were correct about the mosfet (about which I know nothing) but I gave the damaged esc to a friend of a friend etc. and he Is repairing. In the meantime I just ordered a new 15amp Electronize unit and will use the repaired one In the next build. Thanks for all the contributions.
Regards,
Keith.

kwjg51
(Petty Officer)





Forum Posts: 10
26th May 2015 17:59  
>> Permalink
mdlbt.com/17725

HI guys - just received the new 15A Electronize esc. I still have to get the battery pack and am thinking 8.4 V 3800AH. Nimh. How will this set up work. I'm not well up In electronics. My spec Is ... Aerokits Sea Commander with supplied 750 12v motor and 40mm 2 blade prop. Should I have gone for a higher amp esc ? Would you expect the model to plane and how long should It run on a charge ? I had originally Intended to use 12v lead acid but hull space Is a bit too restricted and It Is probably too heavy anyway.

Thank you,

Keith.

Dave M
(Fleet Admiral!)





Forum Posts: 1527
27th May 2015 10:07  
>> Permalink
mdlbt.com/17733

HI Keith
What exactly Is the 750 12v motor? We need to know so that the specs re amps etc can be determined. I can't find any details on the web for a 750.
Regarding the battery It should really be 12v for the motor to work at max efficiency, weight Is always a problem and a lighter battery will help In getting the model on the plane.
You can get 12v NiMhs and the higher the amps the better.
Your ESC should be fine for most motors usually fitted to this model but more details will enable us to confirm.
Cheers
Dave


Live long and prosper

Dave
kwjg51
(Petty Officer)





Forum Posts: 10
27th May 2015 11:35  
>> Permalink
mdlbt.com/17735

Good morning Dave - thanks for getting back to me and sorry for not being clear. The motor Is a Caldercraft 750s which Is supplied as part of the Aerokits Sea Commander kit. On the motor housing Is CEM750S and the code S-2191AE134. The model kits are manufactured by Jotika as you are probably aware and their recommendation Is 7.2v nicad or 12v6ah lead acid using the supplied two blade 40mm plastic prop. I emailed the company who supplied the kit re. esc and power source to be told that their recommendation would be Viper 25amp with either 11.1v lipo or 8.4v nimh. Quite contrary to the manufacturer I think !

In coming back to rc boats after many years I had purchased the particular kit partly because It came Including matched motor, shaft, prop etc. Nice and straightforward with no confusion ?

Ok - my main concern Is the 15amp esc. should I send It back In favour of a 25 or 30amp ?

Thanks Dave,

Keith.

ps the motor spec Is --

Nominal v 12
Range 6 - 12
Max rpm at 12 - 18,800
No load 2.6 amp
Current at 12v - 12.78
Stall 92.08 amp

Is this near the limits of a 15amp esc ?

K.

Dave M
(Fleet Admiral!)





Forum Posts: 1527
27th May 2015 16:49  
>> Permalink
mdlbt.com/17736

HI Keith
The stats I found on the Caldercraft site were:
CEM-750S

Nominal Voltage: 8.4V
Operating Range: 4.8-12V
RPM at Nominal Voltage: 18800
No Load Current: 1A

Fairly similar to what you quote so the 15amp Electronize will be Ideal. As with any electrical kit a fuse Is always a good Idea to protect the model and equipment should a fault develop and the motor gets stalled. According to your figures the stall Is 92Amps but you ESC will shut down well before then. I would use a 15 amp fuse In the positive connection from the main battery.
I suspect the advised battery Is more to do with what's commonly available and the fact that many ESCa (not yours) are limited to <12v. I would go with the 8.4v NiMh you suggested as this will probably give you sufficient performance. You can always buy another battery later If you seek more speed.
Cheers
Dave


Live long and prosper

Dave
kwjg51
(Petty Officer)





Forum Posts: 10
27th May 2015 17:43  
>> Permalink
mdlbt.com/17737

Thanks Dave. Information appreciated.

Keith.