|||
Current Website Support
91
Contributors
13
Subscribers
You are Not Registered
Donate for your silver medal πŸ…
Β£10
Β£15
Β£25
Β£50
Subscribe for your gold medal πŸ…
Β£1
Β£3
Β£5
Β£10
You Will Be Helping Towards:

  • Domain Fees
  • Security Certificates
  • iOS & Android App Fees
  • Website Hosting
  • Fast Servers
  • Data Backups
  • Upkeep & Maintenance
  • Administration Costs

    Without your support the website wouldn't be what it is today.

    Please consider donating towards these fees to help keep us afloat.

    Read more

    All donations are securely managed through PayPal. Amounts donated are not published online.

    Many thanks for your kind support
  • Join Us On Social Media!
    Model Boats Website
    Model Boats Website
    Home
    Forum
    Build Blogs
    Media Gallery
    Boat Clubs & Lakes
    Events
    Boat Harbour
    How-To Articles
    Plans & Docs
    Useful Links
    5

















    Followers
    Mixer problem
    by Elsrickle πŸ‡¬πŸ‡§ ( Warrant Officer)
    πŸ“£










    Click To
    Follow
    16 Posts 15 Replies 0 Photos 23 Likes
    ( Newest Posts Shown First )
    Elsrickle
    Warrant Officer
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡¬πŸ‡§ United Kingdom
    Online: 9 days ago
    😊 View Profile
    πŸ’¬ Send PM
    Hi have tried separate bec from another esc with separate battery and battery pack by itself. Both fitted to receiver bind/batt plug. Still the same.
    Have ordered a turnigy transmitter now. Obviously Spectrums don’t like mixers.
    Elsrickle
    Warrant Officer
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡¬πŸ‡§ United Kingdom
    Online: 9 days ago
    😊 View Profile
    πŸ’¬ Send PM
    Thanks haven’t tried that. Will give it a go
    1
    ToraDog
    Petty Officer 1st Class
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡ΊπŸ‡Έ United States
    Online: 1 day ago
    😊 View Profile
    πŸ’¬ Send PM
    I understand. I am still inclined to think that the issue is in the transmitter, but just for the sake of it, have you tried using an external power source, either a separate BEC or a battery pack, for your receiver package? I am not sure why this makes a difference,, but I have run into it.
    1
    Elsrickle
    Warrant Officer
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡¬πŸ‡§ United Kingdom
    Online: 9 days ago
    😊 View Profile
    πŸ’¬ Send PM
    Sorry my explanation not clear. I meant the bec supply coming from the esc on one.I disconnected the the red +ve wire as is normally done when using two esc’s together. So the receiver only receives one +ve voltage.
    1
    ToraDog
    Petty Officer 1st Class
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡ΊπŸ‡Έ United States
    Online: 1 day ago
    😊 View Profile
    πŸ’¬ Send PM
    I am a little confused,( this is not an arguable point), but it appears that you have run power from one of your ESC's to your BEC?
    If you have a BEC available, then you should be eliminating power from BOTH Esc's. In fact, I was going to suggest eliminating your Esc's as a power source for your receiver package. To do this, disconnect the red lead from the servo plug on both Esc's.
    Jonathan


    Jonathan
    Ianh
    Midshipman
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡ΏπŸ‡¦ South Africa
    Online: 8 hours ago
    😊 View Profile
    πŸ’¬ Send PM
    Hi,
    An age old problem. Spektrum, JR and Hitec all have aircraft mixers and outside of an aircraft can be a real b**ch to programme. The manual(s) supplied are complicated to say the least when you move outside what the radio was designed for.
    1
    Only old in years not mind or soul.
    Elsrickle
    Warrant Officer
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡¬πŸ‡§ United Kingdom
    Online: 9 days ago
    😊 View Profile
    πŸ’¬ Send PM
    Hi am going to try what RN Munich suggests and try switching off mixers.
    If no success will just keep the spectrums on boats without mixers.
    2
    Elsrickle
    Warrant Officer
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡¬πŸ‡§ United Kingdom
    Online: 9 days ago
    😊 View Profile
    πŸ’¬ Send PM
    Must look into manual didn’t know I could switch off mixers. Outputs in all channels set at max motors are identical and fitted on bench have also tried on boats 2 x 600 2 x 400 and two geared motors all identical pairs 2 different kinds of esc’s. Have tried with throttle and aileron, throttle and elevator, and throttle and rudder always the same one motor first and it is always from the esc that is suppling power to bec the other esc has red wire disconnected. I have now tried four different mixers all the same.and followed all the instruction on them.
    All work good on the turnigy which has had no adjustments made to it. That is why it must be in the spectrum transmitters as the 6i has the same problem.
    Elsrickle is the small village where I was brought up.
    Many thanks must get the mixer switched off
    3
    Elsrickle
    Warrant Officer
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡¬πŸ‡§ United Kingdom
    Online: 9 days ago
    😊 View Profile
    πŸ’¬ Send PM
    Have set both channels to max both the same motors ok and matching have done loads of tests problem is definitely in transmitter settings
    2
    Ianh
    Midshipman
    πŸ“ Mixer problem
    Flag
    Country: πŸ‡ΏπŸ‡¦ South Africa
    Online: 8 hours ago
    😊 View Profile
    πŸ’¬ Send PM
    Also have a DX6 that gave me problems in the same situation. I think they are a bit like Hitec, very difficult to set up on non aircraft. Saying that my DX6 is now in a 1:14 semi truck which seems much happier. My Hitec Optic is on the shelf as turning it to 2.4Ghz equals the cost of a new radio!
    2
    Only old in years not mind or soul.
    Show 6 More Posts



    About This Website
    Terms of Service
    Privacy Policy
    Cookies used in this website are gluten free, wheat free and dairy free. By using this website you agree to our use of cookies. More Info